Introduction
Pinned Items
Recent Activities
  • Iv plugged the code reader in and it comes back with P1297
    Does anyone know what this on an MG6 please?
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • mg6troubleshoot created a new forum post in Technical - MG6
    My MG6 has lost power and there is a loud wosh from the turbo when it tries to work. Can anyone tell me where the turbo is on a 1.8 petrol please?
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Car serviced last week, throttle body checked and fine, alternator checked and fine. Hasnt cut out for a couple of weeks and done some long journeys but seemed to happen when a out a mile from home when it was warming up during the winter. 
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • ok thanks, I have it booked in on Friday for a service so Ill ask them to check the alternator. I have noticed the headlights are rubbish but always assumed that because i normally drive a car with LED's i just notice the difference more but maybe its related
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • mg6troubleshoot created a new forum post in Technical - MG6
    Hi, Iv got a 2013 MG6 1.8t. It has an intermittent fault where it just dies whilst driving. All the electrics seem to go to like the fan, radio and no dash lights. Also power steering loss. Does anyone have any ideas?
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • mg6troubleshoot created a new forum post in Technical - MG6
    Iv got a new key dock to replace a suspected faulty switch. How do I get to the top fixing to remove it?

    I can access one via driver footwell, Im guessing I need to remove the radio for the other side?
    Iv got a new key dock to replace a suspected faulty switch. How do I get to the top fixing to remove it?

    I can access one via driver footwell, Im guessing I need to remove the radio for the other side?
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • mg6troubleshoot created a new forum post in Technical - MG6
    Just had an MG6 front pads and discs replaced at Kwikfit. 35k miles and cost £360 quid. Is this a fair price ?
    Just had an MG6 front pads and discs replaced at Kwikfit. 35k miles and cost £360 quid. Is this a fair price ?
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Starting Problems
    yeah looks the same, Just have to keep repeating untill it fires up. what caused it? i wondered if it was the keys
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • mg6troubleshoot created a new forum post in Technical - MG6
    Iv got a 2013 MG6 and it keeps failing to start and takes many attempts to turn over. All the dash lights come on as normal but just doesnt fire up.

    its been getting worse over the last few months. Iv replaced the batter but problem remains
    Iv got a 2013 MG6 and it keeps failing to start and takes many attempts to turn over. All the dash lights come on as normal but just doesnt fire up.

    its been getting worse over the last few months. Iv replaced the batter but problem remains
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
There are no activities here yet
Unable to load tooltip content.
© 2019 The-T-Bar.com All Rights Reserved.

Please publish modules in offcanvas position.