Sign In   Register
Introduction
Pinned Items
Recent Activities
  • I have just picked up my new MG3 today and got black mirror caps to replace the white ones, they have put the standard white ones in the boot so I will have a close look at the fittings and get back to you.
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH replied to the topic Rear brake pads in Technical - MG6
    Thanks for that, MG e mailed me a couple of places that carry after market parts, it is rear brake pads that I am now struggling to get hold of.
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH replied to the topic Rear brake pads in Technical - MG6
    Just an update on this issue, I have just taken the car in to get the pads fitted, the mechanic now tells me they have stopped making the front discs for this model.
    It is five  years old, if there is a problem with the discs the car will be obsolete, it is scandalous.
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH replied to the topic Rear brake pads in Technical - MG6
    Thanks for that, It is a Diesel so will let my mechanic know about Euro car parts.
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH created a new forum post in Technical - MG6
    I have just had my 65 plate MG6 serviced, the guy who did it Could not source rear brake pads, the main dealer said they have stopped making them. The car is only 5 years old how can they stop making parts for it? 
    Has anyone recently had a similar 6 that needed rear pads? How did you get on?
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH replied to the topic Window regulator in Technical - MG6
    Thanks for the reply, unfortunately the dealer has already ordered one of the regulators so I guess I will just have to bite the bullet  in terms of paying for it.
    The dealer I use are usually pretty reasonable in terms of charging so it might not be too bad, they did not charge for looking at the fault and propping the window closed.
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH created a new forum post in Technical - MG6
    Four days ago the front drivers door window on my 65 plate 6 dropped into the door cavity, I took it too my dealer who have managed to wedge it closed until they get a new window regulator.
    Now today, three days later the passenger side has done exactly the same thing ! I am wondering if I am extremely unlucky or this is a common fault ? It has been very hot and I wonder if this has contributed to the problem.
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH replied to the topic Strange fault in Technical - MG6
    I don’t think it is the handbrake as the fault occurs before the car is moved, thanks for the suggestion anyway.
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH replied to the topic Strange fault in Technical - MG6
    Thanks for the reply, it is a strange fault indeed, I have started to wonder if it is something to do with the battery being low, for the last two winters the stop/start on my car has not been working even with very little functions like heating etc running.
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • TonyH created a new forum post in Technical - MG6
    Last week when I started my car (65 plateTL) there was a bang or popping sound which seemed to come from the rear of the car, the main screen went blank and I could not access any of the functions, Radio or Sat Nav etc.
    I was convinced it must be a blown fuse as I couldn’t think of any reason for the bang, everything else still worked and the car dove okay, I got to my destination and the car was left for a couple of hours or more. I started up again and the screen and functions were working again, I was quite surprised as I thought it might be a major fault, it has been okay until today when it did exactly the same thing, worked again after a few hours.
    I have spoken to the local dealer but they have not come across this before, I just wondered if anyone has had a similar experience.
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
There are no activities here yet
Unable to load tooltip content.
© 2020 The-T-Bar.com All Rights Reserved.

Please publish modules in offcanvas position.