MG6 Steering -belt screech

11 months 3 weeks ago #26381 by A. Muse
Anyone else suffering from a screeching steering on full lock?
It seems to have started after I had all of the belts replaced last year (5 year service). MG Dealer replaced the belt again a few weeks ago and it silenced the problem for a couple of days but now it is screeching again. Is it adjustment, or a poor quality belt?

www.mg6register.co.uk The trouble with retirement is you never get a day off!

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago #26836 by Franakapan_Dan
My MG 6 does the same when steering full on (usually when pulling out of a parking space or turning a sharp corner slowly) not sure what it is though sorry... If anyone does know or you managed to find out, would be good to know what it was. :) 

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago #26837 by A. Muse
Replied by A. Muse on topic MG6 Steering -belt screech
I had it on good authority (from someone who built the 6's at Longbridge) that the problem was probably with the belt tensioner (said to be of a lesser quality than those used on the ZT and 75). Problem started at about 50k miles.
I had the belt tensioner replaced 3 weeks ago at the annual service, and so far so good.
I found that the problem was only when the belt was cold or the steering was on hard lock.
I was charged £45 for the tensioner plus a new belt and fitting, plus of course the dreaded VAT   .

www.mg6register.co.uk The trouble with retirement is you never get a day off!

Please Log in or Create an account to join the conversation.

Time to create page: 0.113 seconds
© 2019 The-T-Bar.com All Rights Reserved.

Please publish modules in offcanvas position.