MG6 Cruise Control

7 years 7 months ago #839 by aldon
Replied by aldon on topic MG6 Cruise Control
My cruise control went off today. Cruising at 70.
I pressed the phone button to make a call and it went off with the error message on the screen.

If I touched anything to do with cc it just said the error.

When I stopped I turned off and restarted it then worked for rest of day.
:ohmy:

Please Log in or Create an account to join the conversation.

7 years 7 months ago - 7 years 7 months ago #951 by marshal-beej
Replied by marshal-beej on topic MG6 Cruise Control
My CC failed up the M5 yesterday. Not going from standby to resume either, it was set to about 75 and the car just slowed down, looked at the dash and the CC light was off tried to turn on the CC again with the I/O button and the the cruise control error on the dash. Once I had pulled into the services for a coffee and restarted the engine and it was fine.

www.mg6register.co.uk - The most popular forum for MG6 owners, and home to the official MG6 forum of the MGCC.

Please Log in or Create an account to join the conversation.

7 years 6 months ago #1042 by A. Muse
Replied by A. Muse on topic MG6 Cruise Control
We've joined the club today :ohmy: Cruise control dropped out on the M1 at 72 mph in 5th.
Stopped at the services and was OK when we set off again. Seemed to drop out as it went from drive to over-run as we crested a slight hill. Guess its time to seek out the earth points and give them a scrub ;)

www.mg6register.co.uk The trouble with retirement is you never get a day off!

Please Log in or Create an account to join the conversation.

7 years 6 months ago - 7 years 6 months ago #1076 by KevandAnna
Replied by KevandAnna on topic MG6 Cruise Control
I don't think the Cruise Control problem is earth related. Check out my comments from about 4 weeks ago. MG Motor still don't seem to know what causes the fault and have now moved the data logger from our car to one of their managers. Hopefully they will find a fix for us and in time for the launch of the diesel version! Kevin
The following user(s) said Thank You: A. Muse

Please Log in or Create an account to join the conversation.

7 years 6 months ago #1097 by aldon
Replied by aldon on topic MG6 Cruise Control
After sending details to MG about our failure a few weeks ago there has been no problems since.
Turned it on today and got a flashing cc symbol, tried to engage it buy pressing the thumb wheel and got the cruise control error on the screen.

Only problem we've had with the car so not really complaining but MG do need to get their finger out because something this unsolvable will do nothing but feed the naysayers.

Please Log in or Create an account to join the conversation.

7 years 6 months ago #1101 by SteveT
Replied by SteveT on topic MG6 Cruise Control
I have just completed a drive from Milton Keynes to Scotland and back in my new Magnette SE. The cruise control worked fine until on the way back, driving down the M6 and approaching heavy traffic, I put it on standby and forgot all about it and an hour later when I tried to used again it showed a cruise control fault. After the next stop at services it was OK again. odd!

SteveT

Please Log in or Create an account to join the conversation.

7 years 6 months ago #1102 by marshal-beej
Replied by marshal-beej on topic MG6 Cruise Control

SteveT wrote: I have just completed a drive from Milton Keynes to Scotland and back in my new Magnette SE. The cruise control worked fine until on the way back, driving down the M6 and approaching heavy traffic, I put it on standby and forgot all about it and an hour later when I tried to used again it showed a cruise control fault. After the next stop at services it was OK again. odd!

SteveT


Same sort of fault that the rest of us seem to be seeing

www.mg6register.co.uk - The most popular forum for MG6 owners, and home to the official MG6 forum of the MGCC.

Please Log in or Create an account to join the conversation.

7 years 6 months ago #1113 by KevandAnna
Replied by KevandAnna on topic MG6 Cruise Control
Steve, I've heard nothing back from MG Motor as to if there is any progres trying sort out the CC problem. But when I spoke to Keith Harris when we were at Longbridge several weeks ago, he conceeded that the CC problem was probably going to be more widespread than just with our car, which is exactly what is now unfolding! Hope they get this sorted not only for us, but before they launch the diesel version!! Kevin

Please Log in or Create an account to join the conversation.

7 years 6 months ago #1381 by IainS
Replied by IainS on topic MG6 Cruise Control
I have a similar problem. I could not get the cruise control to work when I first drove the car up from Huddersfield. At that time I put that down to the drivers lack of knowledge.

But I have had it give the same error message (cruise control fault) twice and just stop working until the engine is stopped and restarted.

It mainly seems to happen when when I try to return from standby and touch any of the buttons on the right hand side of the steering wheel.

By the excess of copper ease around all the visable earthing points I think any earthing problems have been already tackled by the previous owner.

It is begining to remind me of a random electrical problem I started having with my ZR after seven years use from new. (The ABS light came on randomly and could be cleared by switching the engine off and on)

That problem with the ZR was one of the reasons for me deciding to buy an MG 6.

It is not a serious problem but the car is just over a year old I hope this is not a sign of things to come. With the holiday season I have not yet taken the car to one of the two Scotish garages for them to look at I will be doing that shortly.

Iain

Please Log in or Create an account to join the conversation.

7 years 6 months ago #1384 by MartinW
Replied by MartinW on topic MG6 Cruise Control
I had the chance a few times over the last few weeks to test ours and it did not give a fault, luckily, and resumed as per normal. The guys at the factory are, as has been said, testing the issue as it appears the earth points are not at fault in this case and it seems to be a programming issue that they're trying to get to the bottom of so hopefully this will be resolved in the future. The joys of electronic gadgetry on cars!

MartinW

Please Log in or Create an account to join the conversation.

7 years 6 months ago - 7 years 6 months ago #1387 by davidj
Replied by davidj on topic MG6 Cruise Control
I have given up using cruise control, not due to the fault which I have only experienced once, as it is always raining and/or heavy traffic and CC isn't safe in either of those conditions.

When the rain stops and the traffic is light I take full advantage to get my average mpg up and CC is not as good at that as I am!

www.mg6register.co.uk - The most popular forum for MG6 owners, and home to the official MG6 forum of the MGCC.

Please Log in or Create an account to join the conversation.

7 years 5 months ago #1397 by Kentishman9
Replied by Kentishman9 on topic MG6 Cruise Control
I have been using my Cruise control on and off since buying my Car in September and it has worked flawlessly. From what I am reading it seems to happen in slightly odd circumstances and clearly the monitoring by MG hasn't produced any clearly identifiable fault. I have to say that when I first had my Magnette I noticed a number of odd things. I then had the mapping / Software update in November and asked them to fix the problem with the Cooling fluid level warning that kept coming on at random. When I got it back they said they had ordered a replacement Cooling Fluid Reservoir as the fault was the level detector. I haven't heard from the dealer since but bizarrely all the problems I was experiencing seem to have gone!!
The following user(s) said Thank You: MartinW

Please Log in or Create an account to join the conversation.

Time to create page: 0.168 seconds
© 2020 The-T-Bar.com All Rights Reserved.

Please publish modules in offcanvas position.