Sign In   Register

MG6 Electrical Faults

6 months 3 weeks ago #26919 by taffyjones
Can anyone help me with some electrical faults I have with my 2012 MG6 1.8 ltr petrol. If I do not use the car for a few days the battery looses its charge. Thinking it was the battery I replaced it with a new one but the problem is still there. When I sit in the car with everything turned off (lights, radio etc.) and before I insert the key I can hear a humming noise as if something is running. Another problem is when I do start the car one of the lights within the Rev Counter (Slip Control System / Traction Control) stays on and a message comes up momentarily Stability Control Fail. I live some distance away from an MG garage so it would be good to have some idea before I pay them a visit. Thanks

Please Log in or Create an account to join the conversation.

6 months 1 week ago #26924 by angelsonefivephilip
Hi Taffy . Mine is a 2012 6 SE Turbo Hatch . The charge issue is the same. The battery goes flat if the car isn't used. The only thing is to run the car every day or trickle charge the battery when not being used or use an Accumate charger? My partners son is a fully qualified technician - he checked the draw on the battery when the car is locked and alarmed. It is on the high side of acceptable. We did buy a bigger battery last time with higher amp hours but same dimensions to fit in the battery box. The light comes on you mention if the battery is disconnected or the charge is too low to be continuous. When you drive away the light should extinguish as the charge returns to normal above say 20 mph. .  Other car makes do the same I'm told. The noise you mention is the electrical systems behind the dash / firewall   winding up such as relays and ecu etc ready for you to start the car. That is nothing to worry about I don't think - mine is the same. Can anyone else confirm what is powering up please? The noise stops and shuts down after about 15 minutes. Good luck - Philip.

Please Log in or Create an account to join the conversation.

6 months 1 week ago - 6 months 1 week ago #26925 by Dom99
Replied by Dom99 on topic MG6 Electrical Faults
It’s just needs a good drive mate for half hour to an hour to charge the battery up think you’ll find that most electric faults will go..... try not to leave it sitting....that’s bad for any car ... if no just keep the battery a trickle charge try not to let the battery go flat eventually if you let the battery go to flat your alarm will start going off to warn you that the battery needs changing. All the best mate. 

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #26942 by Keir462672
Replied by Keir462672 on topic MG6 Electrical Faults
Indeed the noise you hear i beleive is the cooling fan for the entertainment head unit and electrical stuff (think im right as i get that on mine)
Generally if the stability control has an issue you will find its an ABS sensor that is knackered. Generally front Passenger side

Please Log in or Create an account to join the conversation.

Time to create page: 0.231 seconds
© 2021 The-T-Bar.com All Rights Reserved.

Please publish modules in offcanvas position.